View Issue Details

IDProjectCategoryView StatusLast Update
0005445Talerexchangepublic2019-07-28 00:13
ReporterFlorian DoldAssigned ToChristian Grothoff 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005445: emergency payback protocol should support refreshed coins
DescriptionInstead of crediting the customer's reserve, the original coin should simply be credited.

We additionally allow refreshes on coins with revoked denominations, but *only* if this coin has been seen by the exchange before the revocation.
TagsNo tags attached.

Relationships

duplicate of 0005777 assignedFlorian Dold allow recovering refreshed and partially spent coins 
related to 0005446 resolvedChristian Grothoff auditor should count number of coins seen, not just their value 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-09-28 10:45 Florian Dold New Issue
2018-09-28 10:45 Florian Dold Status new => assigned
2018-09-28 10:45 Florian Dold Assigned To => Christian Grothoff
2018-09-28 10:45 Florian Dold Relationship added related to 0005446
2018-10-06 15:08 Christian Grothoff Severity minor => feature
2018-11-18 00:33 Christian Grothoff Product Version => SVN HEAD
2018-11-18 00:33 Christian Grothoff Target Version => 0.7
2019-06-30 17:50 Christian Grothoff Relationship added duplicate of 0005777
2019-07-28 00:13 Christian Grothoff Status assigned => resolved
2019-07-28 00:13 Christian Grothoff Resolution open => duplicate
2019-07-28 00:13 Christian Grothoff Fixed in Version => 0.6
2019-07-28 00:13 Christian Grothoff Target Version 0.7 => 0.6