View Issue Details

IDProjectCategoryView StatusLast Update
0005434Talerwallet (WebExtensions)public2019-12-20 19:11
ReporterFlorian DoldAssigned ToFlorian Dold 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.6Fixed in Version0.6 
Summary0005434: the exchange's /wire response should not include salt for accounts
DescriptionIt seems we're reusing the same structs for signing as we do for the merchant, which incidentally includes a salt (to increase entropy), which is unnecessary if the payto URI is public anyway.
TagsNo tags attached.

Activities

Christian Grothoff

2018-10-06 15:06

manager   ~0013263

Fixed in exchange in 81ce7abe..a56e2e34.
Related merchant updates in f2a5860..9dd7d3d.

Note that I did NOT update the wallet, and if the wallet checks /wire signatures, it should fail now (due to lack of salt). Thus assigning to Florian to ensure Wallet is updated as well.

Florian Dold

2019-12-05 23:21

manager   ~0015126

The wallet part for this has been fixed in 7b54439.

Issue History

Date Modified Username Field Change
2018-09-19 11:35 Florian Dold New Issue
2018-09-19 11:35 Florian Dold Status new => assigned
2018-09-19 11:35 Florian Dold Assigned To => Christian Grothoff
2018-10-06 15:06 Christian Grothoff Note Added: 0013263
2018-10-06 15:06 Christian Grothoff Assigned To Christian Grothoff => Florian Dold
2018-10-06 15:06 Christian Grothoff Category exchange => wallet (WebExtensions)
2018-10-06 15:06 Christian Grothoff Severity minor => tweak
2018-11-18 00:39 Christian Grothoff Target Version => 0.6
2019-12-05 23:21 Florian Dold Status assigned => resolved
2019-12-05 23:21 Florian Dold Resolution open => fixed
2019-12-05 23:21 Florian Dold Note Added: 0015126
2019-12-20 19:11 Christian Grothoff Fixed in Version => 0.6
2019-12-20 19:11 Christian Grothoff Status resolved => closed