View Issue Details

IDProjectCategoryView StatusLast Update
0005287Talerwallet (Android App)public2019-12-20 19:11
ReporterChristian GrothoffAssigned Tonikita 
PrioritynormalSeveritytextReproducibilityhave not tried
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.6Fixed in Version0.6 
Summary0005287: strings not tagged for translation / tagged oddly
DescriptionSome po strings have odd spacing in them in relation to the format strings. Also, it seems not all strings (especially in tipping dialog) have been marked for i18n. Finally, we probably should go together over all of the English text again to polish it a bit before giving it out for translation at scale.
TagsNo tags attached.

Activities

nikita

2019-07-15 19:13

developer   ~0014682

Ack, will get to this after GSoC.
One question: this is 'wallet-webex.git', right?

Christian Grothoff

2019-07-15 19:34

manager   ~0014686

yes

nikita

2019-07-15 19:41

developer   ~0014687

Tack.

nikita

2019-09-02 18:08

developer   ~0014838

I've cleaned up the .po files from strings which no longer exist, added more translatable sections but there's still some pages I need to go through.

nikita

2019-09-03 16:03

developer   ~0014839

I believe except for the /news folder I have everything covered now.

This however reveals "odd strings" as you put it, even after multiple cleanups of the .po files. See stage.taler.net/de/team.html for an example.

I'm now looking into where this might originate from.

nikita

2019-09-03 17:22

developer   ~0014842

For the wrong strings - this seems to be a matter of a translators job.

For the warnings when building on the server, I still have to investigate some more.

nikita

2019-09-03 17:28

developer   ~0014843

https://buildbot.taler.net/#/builders/1/builds/23/steps/1/logs/stdio shows that this part is done:
- Some po strings have odd spacing in them in relation to the format strings.
- Also, it seems not all strings (especially in tipping dialog) have been marked for i18n.


Not done:
- Finally, we probably should go together over all of the English text again to polish it a bit before giving it out for translation at scale.

I'm closing this one and open a new ticket for "polishing the text", as this is another subject

nikita

2019-09-03 17:30

developer   ~0014844

resolved in https://buildbot.taler.net/#/builders/1/builds/23/steps/1/logs/stdio

Issue History

Date Modified Username Field Change
2018-02-22 14:22 Christian Grothoff New Issue
2019-07-15 19:13 nikita Note Added: 0014682
2019-07-15 19:13 nikita Assigned To => Christian Grothoff
2019-07-15 19:13 nikita Status new => assigned
2019-07-15 19:34 Christian Grothoff Note Added: 0014686
2019-07-15 19:41 nikita Note Added: 0014687
2019-07-15 19:41 nikita Assigned To Christian Grothoff => nikita
2019-09-02 18:08 nikita Note Added: 0014838
2019-09-03 16:03 nikita Note Added: 0014839
2019-09-03 17:22 nikita Note Added: 0014842
2019-09-03 17:28 nikita Note Added: 0014843
2019-09-03 17:30 nikita Status assigned => resolved
2019-09-03 17:30 nikita Resolution open => fixed
2019-09-03 17:30 nikita Note Added: 0014844
2019-09-16 09:10 Christian Grothoff Fixed in Version => 0.6
2019-09-16 09:10 Christian Grothoff Target Version 0.7.1 => 0.6
2019-12-20 19:11 Christian Grothoff Status resolved => closed
2019-12-26 21:38 Florian Dold Category wallet (app) => wallet (Android App)