View Issue Details

IDProjectCategoryView StatusLast Update
0004734Talerwallet (WebExtensions)public2022-11-04 20:53
ReporterFlorian Dold Assigned ToChristian Grothoff  
PrioritylowSeverityfeatureReproducibilityhave not tried
Status closedResolutionwon't fix 
Product Version0.9 
Target Version0.9Fixed in Version0.9 
Summary0004734: display what the new balance will be when confirming contracts/reserves
DescriptionSometimes it's a bit hard to see how fees are add up, especially with refresh fees after a purchase.

Thus the UI should always display what the balance will be after we confirm an action that changes it.
TagsNo tags attached.

Activities

Florian Dold

2020-07-16 20:01

manager   ~0016474

I'm really not sure:

* what we would show there with multiple currencies *and* different auditors / exchanges for the same currency
* whether this feature improves anything and why this is necessary

(None of the banks or payment apps that I know show this either!)

This feature complicates the logic for little gain, since the UI would also have to update this balance if it increases or decreases in the background.

I would put this as "improvements for financial literacy" post-1.0.

Christian Grothoff

2020-07-16 22:59

manager   ~0016482

Sure, this is UX stuff that should definitively be discussed more, if possible with Belen.

Christian Grothoff

2022-08-25 20:38

manager   ~0019037

Belen would say less is more, let's not clutter the UI.

Issue History

Date Modified Username Field Change
2016-10-17 16:07 Florian Dold New Issue
2016-10-17 16:07 Florian Dold Status new => assigned
2016-10-17 16:07 Florian Dold Assigned To => Florian Dold
2016-11-15 15:56 Christian Grothoff Severity minor => feature
2016-11-15 15:56 Christian Grothoff Product Version => git (master)
2016-11-15 15:56 Christian Grothoff Target Version => 0.3
2017-04-09 00:29 Christian Grothoff Target Version 0.3 => 0.7.1
2020-07-16 20:01 Florian Dold Assigned To Florian Dold => Christian Grothoff
2020-07-16 20:01 Florian Dold Status assigned => feedback
2020-07-16 20:01 Florian Dold Note Added: 0016474
2020-07-16 22:59 Christian Grothoff Note Added: 0016482
2020-07-16 22:59 Christian Grothoff Assigned To Christian Grothoff =>
2020-07-16 22:59 Christian Grothoff Status feedback => acknowledged
2020-07-16 23:00 Christian Grothoff Priority normal => low
2020-07-16 23:00 Christian Grothoff Product Version git (master) => 0.9
2020-07-16 23:00 Christian Grothoff Target Version 0.7.1 =>
2022-08-25 20:38 Christian Grothoff Assigned To => Christian Grothoff
2022-08-25 20:38 Christian Grothoff Status acknowledged => resolved
2022-08-25 20:38 Christian Grothoff Resolution open => won't fix
2022-08-25 20:38 Christian Grothoff Fixed in Version => 0.9
2022-08-25 20:38 Christian Grothoff Note Added: 0019037
2022-08-25 20:38 Christian Grothoff Target Version => 0.9
2022-11-04 20:53 Christian Grothoff Status resolved => closed