View Issue Details

IDProjectCategoryView StatusLast Update
0004038GNUnettransport servicepublic2023-10-20 16:03
ReporterChristian Grothoff Assigned Toschanzen  
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionno change required 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product VersionGit master 
Target Version0.21.0Fixed in Version0.21.0 
Summary0004038: transport service leaks sockets
DescriptionI see hundreds of these, causing accept() to fail:

gnunet-se 26540 gnunet9 1018u unix 0xffff88103ee160c0 0t0 43811407 /tmp/gnunet-system-runtime//gnunet-service-transport.sock type=STREAM
gnunet-se 26540 gnunet9 1019u unix 0xffff88103c366b40 0t0 43793331 /tmp/gnunet-system-runtime//gnunet-service-transport.sock type=STREAM
gnunet-se 26540 gnunet9 1020u unix 0xffff88103c3664c0 0t0 43793332 /tmp/gnunet-system-runtime//gnunet-service-transport.sock type=STREAM
gnunet-se 26540 gnunet9 1021u unix 0xffff880cebeba480 0t0 43793333 /tmp/gnunet-system-runtime//gnunet-service-transport.sock type=STREAM
gnunet-se 26540 gnunet9 1022u unix 0xffff880cebebbb40 0t0 43793334 /tmp/gnunet-system-runtime//gnunet-service-transport.sock type=STREAM
gnunet-se 26540 gnunet9 1023u unix 0xffff880dc49a0440 0t0 43793335 /tmp/gnunet-system-runtime//gnunet-service-transport.sock type=STREAM
Tagstng

Relationships

related to 0005710 confirmed TNG meta issue 

Activities

Christian Grothoff

2015-10-29 23:13

manager   ~0009857

Ok, 'ss -x' suggests that these sockets are not connected to any other process :-(.

Christian Grothoff

2015-10-30 00:36

manager   ~0009860

Ok, so it seems this is not something that simply happens 'over time': running a peer for a while doesn't show even 2 of those 'extra' connections. So most likely a very large number of them is created at the same time (i.e. due to some error with retries).

schanzen

2023-10-20 16:03

administrator   ~0020600

TNG

Issue History

Date Modified Username Field Change
2015-10-29 23:04 Christian Grothoff New Issue
2015-10-29 23:04 Christian Grothoff Status new => assigned
2015-10-29 23:04 Christian Grothoff Assigned To => Christian Grothoff
2015-10-29 23:13 Christian Grothoff Note Added: 0009857
2015-10-30 00:36 Christian Grothoff Note Added: 0009860
2015-10-31 16:16 Christian Grothoff Priority urgent => normal
2015-10-31 16:16 Christian Grothoff Target Version 0.11.0pre66 => 0.11.0
2018-06-07 00:37 Christian Grothoff Assigned To Christian Grothoff =>
2018-06-07 00:37 Christian Grothoff Status assigned => confirmed
2018-06-07 00:37 Christian Grothoff Target Version 0.11.0 =>
2019-05-02 14:43 Christian Grothoff Relationship added related to 0005710
2020-08-14 12:01 schanzen Tag Attached: tng
2020-10-29 10:09 schanzen Target Version => 0.15.0
2021-06-10 19:36 schanzen Target Version 0.15.0 => 0.16.0
2021-12-31 09:29 schanzen Target Version 0.16.0 => 0.17.0
2021-12-31 09:32 schanzen Target Version 0.17.0 => 1.0.0
2023-10-20 16:03 schanzen Target Version 1.0.0 => 0.21.0
2023-10-20 16:03 schanzen Assigned To => schanzen
2023-10-20 16:03 schanzen Status confirmed => resolved
2023-10-20 16:03 schanzen Resolution open => no change required
2023-10-20 16:03 schanzen Fixed in Version => 0.21.0
2023-10-20 16:03 schanzen Note Added: 0020600