View Issue Details

IDProjectCategoryView StatusLast Update
0003499GNUnetcadet servicepublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToBart Polot 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionduplicate 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003499: got assertion failure in cadet (found core dump) in gnunet-service-cadet_peer.c:1968
Description(gdb) print path->peers[0]
$3 = 17
(gdb) print myid
$4 = 1
(gdb) ba
#0 0x00007f2e9738f407 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007f2e97392508 in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2 0x00007f2e988ac37a in GNUNET_abort () at common_logging.c:289
#3 0x000000000044d49a in GCP_remove_path (peer=0x13b8260, path=0x13cb1e0) at gnunet-service-cadet_peer.c:1968
#4 0x0000000000451a88 in path_destroy_delayed (cls=0x13cb1e0, tc=0x7fff07feb7d0) at cadet_path.c:47
#5 0x00007f2e9890cb08 in run_ready (rs=0x13b0780, ws=0x13b0810) at scheduler.c:595
#6 0x00007f2e9890db97 in GNUNET_SCHEDULER_run (task=0x7f2e98923433 <service_task>, task_cls=0x7fff07febb70) at scheduler.c:817
#7 0x00007f2e989268e6 in GNUNET_SERVICE_run (argc=3, argv=0x7fff07febe08, service_name=0x45afc2 "cadet",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x452e4a <run>, task_cls=0x0) at service.c:1498
#8 0x0000000000453568 in main (argc=3, argv=0x7fff07febe08) at gnunet-service-cadet.c:175
TagsNo tags attached.

Relationships

duplicate of 0003531 closedBart Polot segfault in get_prev_hop 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-07-12 22:57 Christian Grothoff New Issue
2014-07-12 22:57 Christian Grothoff Status new => assigned
2014-07-12 22:57 Christian Grothoff Assigned To => Bart Polot
2014-09-12 02:39 Bart Polot Relationship added duplicate of 0003531
2014-09-12 02:39 Bart Polot Status assigned => resolved
2014-09-12 02:39 Bart Polot Fixed in Version => SVN HEAD
2014-09-12 02:39 Bart Polot Resolution open => duplicate
2014-09-30 10:31 Christian Grothoff Fixed in Version SVN HEAD => 0.11.0pre66
2014-09-30 10:31 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed