View Issue Details

IDProjectCategoryView StatusLast Update
0003498GNUnetcadet servicepublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToBart Polot 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionduplicate 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003498: got core dump from cadet
DescriptionCore was generated by `/home/grothoff/lib//gnunet/libexec/gnunet-service-cadet -c /home/grothoff/.conf'.
Program terminated with signal 11, Segmentation fault.
#0 0x0000000000418da0 in get_next_hop (c=0xca3410) at gnunet-service-cadet_connection.c:740
740 id = c->path->peers[c->own_pos + 1];
(gdb) ba
#0 0x0000000000418da0 in get_next_hop (c=0xca3410) at gnunet-service-cadet_connection.c:740
#1 0x0000000000418f48 in get_hop (c=0xca3410, fwd=1) at gnunet-service-cadet_connection.c:761
#2 0x000000000041af88 in connection_cancel_queues (c=0xca3410, fwd=1) at gnunet-service-cadet_connection.c:1157
#3 0x0000000000426165 in GCC_destroy (c=0xca3410) at gnunet-service-cadet_connection.c:2529
#4 0x000000000041be7c in connection_bck_timeout (cls=0xca3410, tc=0x7fffc5ead220) at gnunet-service-cadet_connection.c:1296
#5 0x00007fe254e26b08 in run_ready (rs=0xc8b780, ws=0xc8b810) at scheduler.c:595
#6 0x00007fe254e27b97 in GNUNET_SCHEDULER_run (task=0x7fe254e3d433 <service_task>, task_cls=0x7fffc5ead5c0) at scheduler.c:817
#7 0x00007fe254e408e6 in GNUNET_SERVICE_run (argc=3, argv=0x7fffc5ead858, service_name=0x45afc2 "cadet",
    options=GNUNET_SERVICE_OPTION_NONE, task=0x452e4a <run>, task_cls=0x0) at service.c:1498
#8 0x0000000000453568 in main (argc=3, argv=0x7fffc5ead858) at gnunet-service-cadet.c:175
(gdb) print c->own_pos
$1 = 0
(gdb) print c->path->peers
$2 = (GNUNET_PEER_Id *) 0x8458eea8238897f9
(gdb) print *c->path
$3 = {next = 0xca48b0, prev = 0xcafb00, peers = 0x8458eea8238897f9, length = 402573578, c = 0xcffbecb04b22e936,
  path_delete = 16231029892936458268}
Steps To ReproduceJust found it from running peer.
TagsNo tags attached.

Relationships

duplicate of 0003531 closedBart Polot segfault in get_prev_hop 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-07-12 22:56 Christian Grothoff New Issue
2014-07-12 22:56 Christian Grothoff Status new => assigned
2014-07-12 22:56 Christian Grothoff Assigned To => Bart Polot
2014-09-12 02:39 Bart Polot Relationship added duplicate of 0003531
2014-09-12 02:39 Bart Polot Status assigned => resolved
2014-09-12 02:39 Bart Polot Fixed in Version => SVN HEAD
2014-09-12 02:39 Bart Polot Resolution open => duplicate
2014-09-30 10:31 Christian Grothoff Fixed in Version SVN HEAD => 0.11.0pre66
2014-09-30 10:31 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed