View Issue Details

IDProjectCategoryView StatusLast Update
0007405Talerwallet (WebExtensions)public2022-11-04 20:52
ReporterChristian Grothoff Assigned ToChristian Grothoff  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Target Version0.9Fixed in Version0.9 
Summary0007405: "Could not load the transaction information" in Webex wallet after refund
DescriptionI get this error instead of the transaction history or something informing me about the refund status:

Could not load the transaction information
unexpected exception (message: BUG: transaction closed before transaction function returned)

{
  "code": 7001,
  "hint": "unexpected exception (message: BUG: transaction closed before transaction function returned)",
  "stack": "runTx/</tx.oncomplete@moz-extension://4b1fa1bb-0e45-4c60-910e-84363229c531/dist/background.js:10661:18\n"
}
Steps To Reproduceafter buying an article in the blog shop and then getting a refund (bottom of page)
TagsNo tags attached.

Activities

sebasjm

2022-10-23 16:28

developer   ~0019278

I have tried some articles and I couldn't reproduce. Can you provide the version number?

Under settings with dev mode activated.

Florian Dold

2022-10-23 18:08

manager   ~0019279

I think this is something that's already fixed in git, but not in the webextension stores.

Christian Grothoff

2022-11-04 19:09

manager   ~0019354

Confirmed fixed.

Issue History

Date Modified Username Field Change
2022-10-22 18:19 Christian Grothoff New Issue
2022-10-22 18:19 Christian Grothoff Status new => assigned
2022-10-22 18:19 Christian Grothoff Assigned To => Florian Dold
2022-10-22 18:19 Christian Grothoff Assigned To Florian Dold => sebasjm
2022-10-22 18:19 Christian Grothoff Priority normal => high
2022-10-22 18:19 Christian Grothoff Target Version => 0.9
2022-10-23 16:28 sebasjm Note Added: 0019278
2022-10-23 16:28 sebasjm Status assigned => feedback
2022-10-23 16:28 sebasjm Assigned To sebasjm => Christian Grothoff
2022-10-23 18:08 Florian Dold Note Added: 0019279
2022-11-04 19:09 Christian Grothoff Status feedback => resolved
2022-11-04 19:09 Christian Grothoff Resolution open => fixed
2022-11-04 19:09 Christian Grothoff Fixed in Version => 0.9
2022-11-04 19:09 Christian Grothoff Note Added: 0019354
2022-11-04 20:52 Christian Grothoff Status resolved => closed