View Issue Details

IDProjectCategoryView StatusLast Update
0007153GNUnetbuild processpublic2022-03-04 22:35
Reporterandrew.dudash Assigned Toschanzen  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSDebian 
Product VersionGit master 
Target Version0.16.1Fixed in Version0.16.1 
Summary0007153: ./configure doesn't AC_MSG_ERROR on missing libsodium
Description`./configure` errors out if `libsodium` is outdated, but it keeps running if it can't find libsodium
Steps To ReproduceUninstall `libsodium`.

Run `./configure`.

Run `make`.

`make` will fail
Additional InformationUpdating configure.ac to include the snippet below would solve the problem:

# check for libsodium
AC_CHECK_LIB([sodium], [sodium_init],
             [],
             [AC_MSG_ERROR([GNUnet requires libsodium >= 1.0.18])])
TagsNo tags attached.

Activities

Christian Grothoff

2022-02-21 00:10

manager   ~0018706

I am confused. We have:


# check for libsodium version >= 1.0.18
AC_CHECK_HEADER([sodium.h],
  [AC_CHECK_LIB([sodium], [crypto_core_ed25519_scalar_mul],
                [libsodium=1],
                [libsodium=0])])

AS_IF([test "x$libsodium" = "x0"],
      [AC_MSG_ERROR([GNUnet requires libsodium >= 1.0.18])])

which seems perfectly adequate. What does your config.log say?

schanzen

2022-02-26 23:23

administrator   ~0018746

This works for me as well. Reporter unresponsive.

schanzen

2022-02-26 23:27

administrator   ~0018747

Actually this does not work. Reopening

schanzen

2022-02-26 23:27

administrator   ~0018748

Fix committed to master branch.

Related Changesets

gnunet: master 82d9ca01

2022-02-26 23:26:33

schanzen

Details Diff
BUILD: Detect missing libsodium. Fixes 0007153 Affected Issues
0007153
mod - configure.ac Diff File
mod - contrib/gana Diff File
mod - po/POTFILES.in Diff File

Issue History

Date Modified Username Field Change
2022-01-20 20:05 andrew.dudash New Issue
2022-02-21 00:10 Christian Grothoff Note Added: 0018706
2022-02-26 23:23 schanzen Assigned To => schanzen
2022-02-26 23:23 schanzen Status new => resolved
2022-02-26 23:23 schanzen Resolution open => no change required
2022-02-26 23:23 schanzen Note Added: 0018746
2022-02-26 23:27 schanzen Status resolved => new
2022-02-26 23:27 schanzen Resolution no change required => reopened
2022-02-26 23:27 schanzen Note Added: 0018747
2022-02-26 23:27 schanzen Changeset attached => gnunet master 82d9ca01
2022-02-26 23:27 schanzen Note Added: 0018748
2022-02-26 23:27 schanzen Status new => resolved
2022-02-26 23:27 schanzen Resolution reopened => fixed
2022-02-26 23:28 schanzen Target Version => 0.16.1
2022-03-04 22:35 schanzen Status resolved => closed
2022-03-04 22:35 schanzen Fixed in Version => 0.16.1