View Issue Details

IDProjectCategoryView StatusLast Update
0006203Talerdeployment and operationspublic2020-07-24 11:56
ReporterbuckE Assigned TobuckE  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version0.8Fixed in Version0.8 
Summary0006203: weblate: systemd service run by weblate user
DescriptionChristian suggested running the systemd file by a non-priv user. (Not running *as* weblate user but running *by* weblate user so Christian would not have to start weblate.service.)

CHRISTIAN: please provide a link to what you mean. I did not know this is possible, but assumed root had to add to /etc/systemd/system regardless of user/owner?

Also you said you would have to add weblate user to the right group. Which group, just because I am curious? Please let me know when you did that and reassign to me and I'll investigate.

(Alternatively, I could run this as a cron job or even a screen session permanently under weblate?)
TagsNo tags attached.

Activities

Christian Grothoff

2020-04-23 11:14

manager   ~0015748

https://wiki.archlinux.org/index.php/Systemd/User

I've activated lingering (# loginctl enable-linger weblate) for the weblate user.

buckE

2020-04-24 06:58

reporter   ~0015771

Great! We are successful for weblate.service and celery-weblate services running locally. weblate user is logged out but the site is still up at https://weblate.taler.net/ Closing issue.

Issue History

Date Modified Username Field Change
2020-04-23 06:23 buckE New Issue
2020-04-23 06:23 buckE Status new => assigned
2020-04-23 06:23 buckE Assigned To => Christian Grothoff
2020-04-23 11:14 Christian Grothoff Note Added: 0015748
2020-04-23 11:39 Christian Grothoff Assigned To Christian Grothoff => buckE
2020-04-24 06:58 buckE Status assigned => resolved
2020-04-24 06:58 buckE Resolution open => fixed
2020-04-24 06:58 buckE Note Added: 0015771
2020-07-24 11:56 Christian Grothoff Target Version => 0.8
2020-07-24 11:56 Christian Grothoff Fixed in Version => 0.8