View Issue Details

IDProjectCategoryView StatusLast Update
0006043Talerwallet (WebExtensions)public2020-04-07 14:44
ReporterChristian GrothoffAssigned TobuckE 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Platformi7OSDebian GNU/LinuxOS Versionsqueeze
Product Versiongit (master) 
Target Version0.7.1Fixed in Version0.7.1 
Summary0006043: test webextensions wallet on Brave
DescriptionTorsten Grothoff reports it works, we should confirm and if so add Brave to the list of supported browsers on the Web site.
TagsNo tags attached.

Relationships

related to 0006042 assignedFlorian Dold test webextensions wallet on GNU IceCat 

Activities

buckE

2020-04-04 03:55

developer   ~0015520

Confirmed working on Brave Version 1.5.123 Chromium: 80.0.3987.163 (Official Build) (64-bit)

Tested:

 - withdraw 5 kudos from demo
 - Circle-T icon shows in browser chrome next to hamburger menu
 - Clicking Circle-T icon brings up wallet
     Balance shown correctly
     History shown correctly
     Debug tools shown and seem to work, except:
         NOTE: ERR_FILE_NOT_FOUND errors for these buttons:
                show tree: chrome-extension://millncjiddlpgdmkklmhfadpacifaonc/src/webex/pages/tree.html
                show logs: chrome-extension://millncjiddlpgdmkklmhfadpacifaonc/src/webex/pages/logs.html

Is there some other test I should run?

If not, I recommend adding Brave compatibility to the website as follows:

*Chromium Extension*
Tested with:
    Chromium v. X
    Brave Version 1.5.123 Chromium: 80.0.3987.163 (Official Build) (64-bit)
[Install Chromium Extension]

Marking "resolved." Please reopen if there are further tests I should run.

buckE

2020-04-04 04:36

developer   ~0015522

Marking "resolved." Please reopen if there are further tests I should run.

Christian Grothoff

2020-04-04 10:31

manager   ~0015526

Technically, there is also refunds (buy an RMS article, scroll to the bottom, find the [demand a refund] button), and tipping. However, the tipping demo is known to be flaky/broken for all wallets right now (because of the server-side setup), so that I wouldn't expect to work.
Anyway, that's just FYI for what we can/should/would ideally test if we do 'full tests', but I doubt Brave vs. Chromium truly warrants this. I'm a bit confused as to why the tree/logs.html are not found, but those ALSO fail on Firefox. So this is NOT related to Brave at all.
Can you please go ahead and modify www.git to declare Brave supported as you proposed?

Issue History

Date Modified Username Field Change
2020-01-12 22:30 Christian Grothoff New Issue
2020-01-12 22:30 Christian Grothoff Status new => assigned
2020-01-12 22:30 Christian Grothoff Assigned To => Florian Dold
2020-01-12 22:30 Christian Grothoff Assigned To Florian Dold => Christian Grothoff
2020-01-12 22:30 Christian Grothoff Relationship added related to 0006042
2020-01-14 10:23 Christian Grothoff Assigned To Christian Grothoff => gmarcos87
2020-01-17 00:35 Christian Grothoff Target Version 0.6 => 0.7.1
2020-03-17 02:09 Christian Grothoff Assigned To gmarcos87 =>
2020-03-17 02:09 Christian Grothoff Status assigned => confirmed
2020-03-29 21:59 Christian Grothoff Target Version 0.7.1 => 0.7.2
2020-04-02 10:00 Christian Grothoff Assigned To => buckE
2020-04-02 10:00 Christian Grothoff Status confirmed => assigned
2020-04-04 03:55 buckE Note Added: 0015520
2020-04-04 04:36 buckE Status assigned => resolved
2020-04-04 04:36 buckE Resolution open => fixed
2020-04-04 04:36 buckE Note Added: 0015522
2020-04-04 10:31 Christian Grothoff Note Added: 0015526
2020-04-07 14:44 Christian Grothoff Fixed in Version => 0.7.1
2020-04-07 14:44 Christian Grothoff Target Version 0.7.2 => 0.7.1