View Issue Details

IDProjectCategoryView StatusLast Update
0005748Talerwallet (WebExtensions)public2019-06-25 14:56
ReporterFlorian DoldAssigned ToFlorian Dold 
PriorityurgentSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version0.6Fixed in Version 
Summary0005748: wallet has problems with multiple denominations
DescriptionWhen having both KUDOS and TESTKUDOS in the wallet, I can't pay with TESTKUDOS anymore, as the wallet complains that there is no matching currency. That is obviously wrong.
TagsNo tags attached.

Activities

Florian Dold

2019-06-03 12:22

manager   ~0014501

This is actually caused by the two exchanges having the same master key.

That shouldn't happen in the first place, but the wallet should handle this gracefully, by refusing to add the exchange or "replace" the old exchange.

Florian Dold

2019-06-25 14:56

manager   ~0014594

Resolving this since it's not a bug in the wallet.

Testing how the wallet deals with weird exchange behavior is tracked in 0005775

Issue History

Date Modified Username Field Change
2019-06-03 11:58 Florian Dold New Issue
2019-06-03 11:58 Florian Dold Status new => assigned
2019-06-03 11:58 Florian Dold Assigned To => Florian Dold
2019-06-03 12:22 Florian Dold Note Added: 0014501
2019-06-25 14:56 Florian Dold Status assigned => resolved
2019-06-25 14:56 Florian Dold Resolution open => fixed
2019-06-25 14:56 Florian Dold Note Added: 0014594