View Issue Details

IDProjectCategoryView StatusLast Update
0005741Talerdeployment and operationspublic2019-09-16 09:22
ReporterFlorian DoldAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005741: auditor reports should not be in the top-level $HOME of the demo/test account
DescriptionPlease fix the configuration for this in deployment.git and apply this to test-{green,blue}.
TagsNo tags attached.

Activities

Marcello Stanisci

2019-05-29 21:20

manager   ~0014459

fixed here, and tested with forced builds: 4883a76. Next build is at 6AM; if it behaves well, I'll close this.

Marcello Stanisci

2019-05-30 09:38

manager   ~0014460

Made this (4883a76..e406458) to remove the .txt(s) from $HOME, but the PDF got placed under "shared-data/". Closing.

Florian Dold

2019-05-31 09:53

manager   ~0014473

I'm still seeing audit reports as of now on test-green:

audit_report.2019-05-31.txt
...

Marcello Stanisci

2019-05-31 10:27

manager   ~0014474

Last edited: 2019-05-31 10:28

View 3 revisions

The .txt from the 30 may are due to a bug that made .txt not deleted (fixed here: e4064589a77bbe). The txt/tex from the 31 may are there because the builder failed this morning, and so the script didn't reach the point where it actually deletes those.

See here: https://buildbot.taler.net/#/builders/2/builds/28

That's odd because the PDF transformation was working fine unitil yesterday, and there isn't even any change in the JSON ouput of the taler-auditor command. Well, I've patched it anyway: 4d81c44..03d1186 (@ deployment.git).

Ah, 0005742 is there to track this problem!

Marcello Stanisci

2019-05-31 10:32

manager   ~0014475

Also to be noted: strictly speaking, those are not reports, but just some intermediate data that is used to produce the final report in PDF. This one then gets moved under ~/shared-data/auditor/reports, and served at https://auditor.test.taler.net/reports

Issue History

Date Modified Username Field Change
2019-05-29 17:35 Florian Dold New Issue
2019-05-29 17:35 Florian Dold Status new => assigned
2019-05-29 17:35 Florian Dold Assigned To => Marcello Stanisci
2019-05-29 21:20 Marcello Stanisci Note Added: 0014459
2019-05-30 09:38 Marcello Stanisci Note Added: 0014460
2019-05-30 09:38 Marcello Stanisci Status assigned => resolved
2019-05-30 09:38 Marcello Stanisci Resolution open => fixed
2019-05-31 09:53 Florian Dold Note Added: 0014473
2019-05-31 10:27 Marcello Stanisci Note Added: 0014474
2019-05-31 10:28 Marcello Stanisci Note Edited: 0014474 View Revisions
2019-05-31 10:28 Marcello Stanisci Note Edited: 0014474 View Revisions
2019-05-31 10:32 Marcello Stanisci Note Added: 0014475
2019-09-16 09:22 Christian Grothoff Product Version => SVN HEAD
2019-09-16 09:22 Christian Grothoff Fixed in Version => 0.6
2019-09-16 09:22 Christian Grothoff Target Version => 0.6