View Issue Details

IDProjectCategoryView StatusLast Update
0005365Talermechant backendpublic2018-07-02 10:27
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005365: Caching results makes testing difficult.
DescriptionBoth /track/transaction and /track/transfer from the merchant use to cache the response from the exchange. Although this helps for performance, this makes harder to get those two API endpoint Twister-tested.

So this issue claims that a new utility/technique should be developed so that Twister-testing /track/transaction and /track/transfer becomes easier and faster.
TagsNo tags attached.

Relationships

related to 0005366 resolvedMarcello Stanisci Need payment generator for corner cases. 
child of 0004930 resolvedMarcello Stanisci Render 'conflict' errors due to /track operations. 

Activities

Marcello Stanisci

2018-06-26 15:47

manager   ~0013084

Last edited: 2018-06-26 15:48

View 2 revisions

There is no way to interfere with how caching is carried out. In other words, there is no way to not use cached results to track order_id x on the second request of /track/transaction for x.

However, more and more x-like orders can be created, so that the tester does not run out of trackable orders "soon".

Marcello Stanisci

2018-06-28 21:45

manager   ~0013108

0d2b620 implements "rewinding" of CMDs for the "alt" payment generator. The ordinary payment generator had already this feature. The issue stays open to remind that manual tests via the back-office site have to be done.

Marcello Stanisci

2018-06-29 09:42

manager   ~0013112

Manual test passed. Give the following command to generate 'n' payment entries, each of which gets its individual wire transfer.

$ taler-merchant-generate-payments-alt -m http://merchant -b http://bank -i X -t 'n'

Issue History

Date Modified Username Field Change
2018-06-26 15:13 Marcello Stanisci New Issue
2018-06-26 15:13 Marcello Stanisci Status new => assigned
2018-06-26 15:13 Marcello Stanisci Assigned To => Marcello Stanisci
2018-06-26 15:26 Marcello Stanisci Relationship added child of 0004930
2018-06-26 15:27 Marcello Stanisci Relationship added related to 0005366
2018-06-26 15:47 Marcello Stanisci Note Added: 0013084
2018-06-26 15:48 Marcello Stanisci Note Edited: 0013084 View Revisions
2018-06-28 21:45 Marcello Stanisci Note Added: 0013108
2018-06-29 09:42 Marcello Stanisci Note Added: 0013112
2018-06-29 09:42 Marcello Stanisci Status assigned => resolved
2018-06-29 09:42 Marcello Stanisci Resolution open => fixed
2018-07-02 10:27 Christian Grothoff Product Version => SVN HEAD
2018-07-02 10:27 Christian Grothoff Fixed in Version => 0.6