View Issue Details

IDProjectCategoryView StatusLast Update
0005338Talertwisterpublic2019-01-31 19:33
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005338: Machine state not changed to "upload started".
Description_Sometimes_, and NOT under Valgrind, the twister fails to set the machine state as REQUEST_STATE_UPLOAD_STARTED, making the first assert from curl_upload_cb() fail.
Additional InformationMay 24 18:53:06-963367 test-merchant-api-twisted-11011 DEBUG Running command `create-proposal-0'
May 24 18:53:06-963583 taler-merchant-httpd-11040 WARNING Failed to parse JSON request body
May 24 18:53:06-963590 twister-11046 ERROR Assertion failed at taler-twister-service.c:596.
May 24 18:53:06-963633 twister-11046 ERROR Download curl failed: Operation was aborted by an application callback
May 24 18:53:23-014677 test-merchant-api-twisted-11011 WARNING Did NOT detect response as JSON
May 24 18:53:23-014705 test-merchant-api-twisted-11011 ERROR Assertion failed at testing_api_cmd_proposal.c:287.
TagsNo tags attached.

Activities

Marcello Stanisci

2018-06-06 12:27

manager   ~0012983

Appeared again: https://buildbot.taler.net/#/builders/5/builds/1631

Marcello Stanisci

2018-09-20 17:21

manager   ~0013248

Not sure how to reproduce, and lots of changes happened in the meantime.

Putting as 'feedback', and likely to be soon closed without touching the code.

Marcello Stanisci

2018-12-20 23:11

manager   ~0013431

This bug has only showed up a few times since this issue was filed, and never did anymore (even though the Twister got extensively used until now). Moreover, significant changes also occurred in the Twister code. No need to keep this open.

Issue History

Date Modified Username Field Change
2018-06-01 16:41 Marcello Stanisci New Issue
2018-06-01 16:41 Marcello Stanisci Status new => assigned
2018-06-01 16:41 Marcello Stanisci Assigned To => Marcello Stanisci
2018-06-06 12:27 Marcello Stanisci Note Added: 0012983
2018-09-20 17:21 Marcello Stanisci Status assigned => feedback
2018-09-20 17:21 Marcello Stanisci Note Added: 0013248
2018-12-20 23:11 Marcello Stanisci Status feedback => resolved
2018-12-20 23:11 Marcello Stanisci Resolution open => no change required
2018-12-20 23:11 Marcello Stanisci Note Added: 0013431
2019-01-31 19:33 Christian Grothoff Product Version => SVN HEAD
2019-01-31 19:33 Christian Grothoff Fixed in Version => 0.6