View Issue Details

IDProjectCategoryView StatusLast Update
0005332Talermechant backendpublic2018-07-03 22:58
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version0.5 
Target Version0.6Fixed in Version0.6 
Summary0005332: Address FIXMEs at test cases.
DescriptionTests cases have a few FIXMEs that need to be addressed,
especially the ones accounting for "unused fields" in some
CMDs state.
TagsNo tags attached.

Activities

Marcello Stanisci

2018-07-02 11:41

manager   ~0013126

To be answered:

https://git.taler.net/exchange.git/tree/src/exchange-lib/testing_api_cmd_refresh.c#n351

Marcello Stanisci

2018-07-02 22:16

manager   ~0013127

e3e3107 fixes everything BUT a last FIXME from the track-transfer CMD at the merchant.

Marcello Stanisci

2018-07-03 10:26

manager   ~0013128

The commit mentioned above actually closes this bug, because it led to some incompleteness (see 0005382, 0005383) in the merchant logic itself.

Issue History

Date Modified Username Field Change
2018-05-24 18:39 Marcello Stanisci New Issue
2018-05-24 18:39 Marcello Stanisci Status new => assigned
2018-05-24 18:39 Marcello Stanisci Assigned To => Marcello Stanisci
2018-05-24 18:39 Marcello Stanisci Target Version => 0.6
2018-07-02 11:41 Marcello Stanisci Note Added: 0013126
2018-07-02 22:16 Marcello Stanisci Note Added: 0013127
2018-07-03 10:26 Marcello Stanisci Status assigned => resolved
2018-07-03 10:26 Marcello Stanisci Resolution open => fixed
2018-07-03 10:26 Marcello Stanisci Note Added: 0013128
2018-07-03 22:58 Christian Grothoff Product Version => 0.5
2018-07-03 22:58 Christian Grothoff Fixed in Version => 0.6