View Issue Details

IDProjectCategoryView StatusLast Update
0005331Talerotherpublic2018-06-12 08:59
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0005331: Payments generator complains about denom expiration date.
DescriptionRunning the payments generator shows the following problem.
However, the generator uses _always_ the local configuration, so this
is not necessarily a bug from it.

May 24 16:34:25-306909 taler-merchant-generate-payments-new-3468 WARNING Have denomination key for `USD:5', but with wrong expiration range 1527172465306902 vs [1525337890000000,1525942690000000)
May 24 16:34:25-306940 taler-merchant-generate-payments-new-3468 ERROR Failed to determine denomination key at withdraw-coin-1
May 24 16:34:25-306944 taler-merchant-generate-payments-new-3468 ERROR Assertion failed at testing_api_cmd_withdraw.c:353.
Aborted
TagsNo tags attached.

Activities

Marcello Stanisci

2018-06-05 18:20

manager   ~0012980

As suspected, this was due to a error in the local configuration.

Issue History

Date Modified Username Field Change
2018-05-24 16:37 Marcello Stanisci New Issue
2018-05-24 16:38 Marcello Stanisci Assigned To => Marcello Stanisci
2018-05-24 16:38 Marcello Stanisci Status new => assigned
2018-06-05 18:20 Marcello Stanisci Status assigned => resolved
2018-06-05 18:20 Marcello Stanisci Resolution open => no change required
2018-06-05 18:20 Marcello Stanisci Note Added: 0012980
2018-06-12 08:59 Christian Grothoff Product Version => SVN HEAD
2018-06-12 08:59 Christian Grothoff Fixed in Version => 0.6