View Issue Details

IDProjectCategoryView StatusLast Update
0005277Talerexchangepublic2018-09-15 11:06
ReporterMarcello StanisciAssigned ToMarcello Stanisci 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version0.6Fixed in Version0.6 
Summary0005277: Address WARNINGs in new "cherry pick" test-suite.
DescriptionThe new "cherry pick" test suite doesn't get the second batch of denomination
keys signed by the auditor, therefore showing the warnings pasted below.

This second batch is generated by the command labelled "keyup-2".

The command which should fail to sign the keys is labelled "sign-keys-1";
clearly, the command might succeed to sign those, but maybe storing the
signature in a weird place..
Additional Information
Feb 12 14:48:33-627473 taler-exchange-httpd-5031 INFO (re-)loading keys
Feb 12 14:48:33-627506 taler-exchange-httpd-5031 INFO Loading keys from `/home/marcello/prog/taler/exchange/src/exchange-lib/test_exchange_api_home//.local/share/taler//exchange/live-keys/'
Feb 12 14:48:33-627590 taler-exchange-httpd-5031 DEBUG Loading denomination key `EUR_0_01-DPT6XTHK2W5VC3T78SX2' (1DG63SK4)
Feb 12 14:48:33-627945 taler-exchange-httpd-5031 INFO Adding denomination key `EUR_0_01-DPT6XTHK2W5VC3T78SX2' (1DG63SK4) to active set
Feb 12 14:48:33-628014 taler-exchange-httpd-5031 DEBUG Loading denomination key `EUR_0_01-DPT6XTHK2W5VC3T78SX2' (0WHDF5J4)
Feb 12 14:48:33-629522 taler-exchange-httpd-5031 INFO Adding denomination key `EUR_0_01-DPT6XTHK2W5VC3T78SX2' (0WHDF5J4) to active set
Feb 12 14:48:33-629590 taler-exchange-httpd-5031 DEBUG Loading denomination key `EUR_0_01-DPT6XTHK2W5VC3T78SX2' (VB7EMRFN)
Feb 12 14:48:33-631099 taler-exchange-httpd-5031 INFO Adding denomination key `EUR_0_01-DPT6XTHK2W5VC3T78SX2' (VB7EMRFN) to active set
Feb 12 14:48:33-631172 taler-exchange-httpd-5031 DEBUG Loading denomination key `EUR_0_01-DPT6XTHK2W5VC3T78SX2' (9K2KVRNQ)
Feb 12 14:48:33-631512 taler-exchange-httpd-5031 INFO Adding denomination key `EUR_0_01-DPT6XTHK2W5VC3T78SX2' (9K2KVRNQ) to active set
Feb 12 14:48:33-631596 taler-exchange-httpd-5031 DEBUG Loading denomination key `EUR_0_02-AJ6DSJY5FKH1YXBBTG4V' (8F9G0GSV)
Feb 12 14:48:33-631884 taler-exchange-httpd-5031 INFO Adding denomination key `EUR_0_02-AJ6DSJY5FKH1YXBBTG4V' (8F9G0GSV) to active set
Feb 12 14:48:33-631953 taler-exchange-httpd-5031 DEBUG Loading denomination key `EUR_0_02-AJ6DSJY5FKH1YXBBTG4V' (ZZ5467BF)
Feb 12 14:48:33-633338 taler-exchange-httpd-5031 INFO Adding denomination key `EUR_0_02-AJ6DSJY5FKH1YXBBTG4V' (ZZ5467BF) to active set
Feb 12 14:48:33-633403 taler-exchange-httpd-5031 DEBUG Loading denomination key `EUR_0_02-AJ6DSJY5FKH1YXBBTG4V' (ASSNQCBJ)
Feb 12 14:48:33-634966 taler-exchange-httpd-5031 INFO Adding denomination key `EUR_0_02-AJ6DSJY5FKH1YXBBTG4V' (ASSNQCBJ) to active set
Feb 12 14:48:33-635063 taler-exchange-httpd-5031 DEBUG Loading denomination key `EUR_0_02-AJ6DSJY5FKH1YXBBTG4V' (R3R550M1)
Feb 12 14:48:33-635558 taler-exchange-httpd-5031 INFO Adding denomination key `EUR_0_02-AJ6DSJY5FKH1YXBBTG4V' (R3R550M1) to active set
Feb 12 14:48:33-635661 taler-exchange-httpd-5031 DEBUG Found auditor signature for DK `ASSNQCBJ'
Feb 12 14:48:33-635671 taler-exchange-httpd-5031 DEBUG Found auditor signature for DK `ZZ5467BF'
Feb 12 14:48:33-635677 taler-exchange-httpd-5031 DEBUG Found auditor signature for DK `VB7EMRFN'
Feb 12 14:48:33-635683 taler-exchange-httpd-5031 DEBUG Found auditor signature for DK `0WHDF5J4'
Feb 12 14:48:33-635693 taler-exchange-httpd-5031 WARNING Denomination key `R3R550M1' at 0xb8e40a18 not signed by any auditor!
Feb 12 14:48:33-635699 taler-exchange-httpd-5031 WARNING Denomination key `9K2KVRNQ' at 0xb8e40a64 not signed by any auditor!
Feb 12 14:48:33-635704 taler-exchange-httpd-5031 WARNING Denomination key `8F9G0GSV' at 0xb8e40ab0 not signed by any auditor!
Feb 12 14:48:33-635709 taler-exchange-httpd-5031 WARNING Denomination key `1DG63SK4' at 0xb8e40afc not signed by any auditor!
TagsNo tags attached.

Activities

Marcello Stanisci

2018-06-29 15:17

manager   ~0013117

124ae0d5 fixes it. The problem was that the CMD that signed the keys on behalf of the auditor used to _overwrite_ the old auditor-signed blob, therefore making the first batch of keys NOT auditor-signed anymore.

Issue History

Date Modified Username Field Change
2018-02-12 14:54 Marcello Stanisci New Issue
2018-02-12 14:54 Marcello Stanisci Status new => assigned
2018-02-12 14:54 Marcello Stanisci Assigned To => Christian Grothoff
2018-02-12 14:55 Marcello Stanisci Assigned To Christian Grothoff => Marcello Stanisci
2018-02-12 14:55 Marcello Stanisci Summary Address WARNINGs in new test-suite. => Address WARNINGs in new "cherry pick" test-suite.
2018-02-12 14:56 Marcello Stanisci Target Version => 0.6
2018-02-12 14:57 Marcello Stanisci Additional Information Updated View Revisions
2018-06-29 15:17 Marcello Stanisci Note Added: 0013117
2018-06-29 15:18 Marcello Stanisci Status assigned => resolved
2018-06-29 15:18 Marcello Stanisci Resolution open => fixed
2018-09-15 11:06 Christian Grothoff Fixed in Version => 0.6