View Issue Details

IDProjectCategoryView StatusLast Update
0003508GNUnetcadet servicepublic2018-06-07 00:25
ReporterSree Harsha TotakuraAssigned ToBart Polot 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformarmv7lOSOS Version
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003508: CADET taking too much memory
DescriptionCADET service is taking a lot of memory (about 300 MB) on one of the tiny ARM
computers I am testing which has 512MB of memory. As a result, the processes
are getting killed by OOM and the testcases are all failing except for the first
two:

PASS: test_cadet_single
PASS: test_cadet_local.
Additional InformationThis is the output I see from dmesg:
<6>lowmemorykiller: Killing 'gnunet-service-' (25651), adj 0,
   to free 328112kB on behalf of 'gnunet-service-' (25651) because
   cache 6080kB is below limit 6144kB for oom_score_adj 0
   Free memory is -1520kB above reserved
[17578.156853] lowmemorykiller: Killing 'gnunet-service-' (25651), adj 0,
[17578.156861] to free 328112kB on behalf of 'gnunet-service-' (25651) because
[17578.156866] cache 6080kB is below limit 6144kB for oom_score_adj 0
[17578.156871] Free memory is -1520kB above reserved
<6>lowmemorykiller: Killing 'gnunet-service-' (25651), adj 0,
   to free 328112kB on behalf of 'rs:main Q:Reg' (1667) because
   cache 6080kB is below limit 6144kB for oom_score_adj 0
   Free memory is -1520kB above reserved
[17578.202540] lowmemorykiller: Killing 'gnunet-service-' (25651), adj 0,
[17578.202547] to free 328112kB on behalf of 'rs:main Q:Reg' (1667) because
[17578.202552] cache 6080kB is below limit 6144kB for oom_score_adj 0
[17578.202557] Free memory is -1520kB above reserved
<6>lowmemorykiller: Killing 'gnunet-service-' (25651), adj 0,
   to free 328112kB on behalf of 'kswapd0' (21) because
   cache 6080kB is below limit 6144kB for oom_score_adj 0
   Free memory is -1520kB above reserved
[17578.248536] lowmemorykiller: Killing 'gnunet-service-' (25651), adj 0,
[17578.248543] to free 328112kB on behalf of 'kswapd0' (21) because
[17578.248547] cache 6080kB is below limit 6144kB for oom_score_adj 0
[17578.248552] Free memory is -1520kB above reserved
<6>lowmemorykiller: Killing 'gnunet-service-' (26711), adj 0,
   to free 327224kB on behalf of 'kswapd0' (21) because
   cache 6064kB is below limit 6144kB for oom_score_adj 0
   Free memory is -748kB above reserved
[17666.131218] lowmemorykiller: Killing 'gnunet-service-' (26711), adj 0,
[17666.131225] to free 327224kB on behalf of 'kswapd0' (21) because
[17666.131230] cache 6064kB is below limit 6144kB for oom_score_adj 0
[17666.131235] Free memory is -748kB above reserved
TagsNo tags attached.

Activities

Bart Polot

2015-01-15 16:22

manager   ~0008777

Does this still happen? I can't reproduce.

Christian Grothoff

2015-03-08 13:31

manager   ~0009004

Seems fine to me now. CORE, FS, TRANSPORT are now way more worrysome...

Issue History

Date Modified Username Field Change
2014-07-31 16:55 Sree Harsha Totakura New Issue
2014-07-31 16:55 Sree Harsha Totakura Status new => assigned
2014-07-31 16:55 Sree Harsha Totakura Assigned To => Bart Polot
2014-07-31 16:56 Sree Harsha Totakura Description Updated View Revisions
2014-07-31 16:56 Sree Harsha Totakura Description Updated View Revisions
2014-07-31 17:00 Sree Harsha Totakura Platform ARM => armv7l
2014-11-07 18:51 Christian Grothoff Target Version => 0.11.0pre66
2015-01-15 16:22 Bart Polot Note Added: 0008777
2015-01-15 16:22 Bart Polot Status assigned => feedback
2015-03-08 13:31 Christian Grothoff Note Added: 0009004
2015-03-08 13:31 Christian Grothoff Status feedback => resolved
2015-03-08 13:31 Christian Grothoff Fixed in Version => 0.11.0pre66
2015-03-08 13:31 Christian Grothoff Resolution open => fixed
2018-06-07 00:25 Christian Grothoff Status resolved => closed