View Issue Details

IDProjectCategoryView StatusLast Update
0003269GNUnettransport servicepublic2018-06-07 00:25
ReporterChristian GrothoffAssigned ToChristian Grothoff 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.11.0pre66Fixed in Version0.11.0pre66 
Summary0003269: transport plugin monitoring API
DescriptionIt would be nice to have an API to monitor which sessions are active at any plugin (with address) and to see when the plugin would time them out. This would require an extended transport service API, passing the requests to the plugin and thus also an extended plugin API.
TagsNo tags attached.

Relationships

duplicate of 0003452 closedChristian Grothoff complete implementation of plugin monitoring API 

Activities

Christian Grothoff

2014-04-16 12:01

manager   ~0008256

Once this is implemented, we should also update gnunet-peerinfo-gtk to make use of it (see 0003265).

Christian Grothoff

2014-12-12 01:26

manager   ~0008671

Has been done.

Issue History

Date Modified Username Field Change
2014-01-10 13:28 Christian Grothoff New Issue
2014-01-10 13:28 Christian Grothoff Status new => assigned
2014-01-10 13:28 Christian Grothoff Assigned To => Matthias Wachs
2014-04-11 15:12 Christian Grothoff Priority normal => high
2014-04-11 15:12 Christian Grothoff Target Version => 0.11.0pre66
2014-04-11 15:26 Christian Grothoff Priority high => urgent
2014-04-11 15:26 Christian Grothoff Relationship added child of 0003265
2014-04-16 12:01 Christian Grothoff Note Added: 0008256
2014-04-16 12:01 Christian Grothoff Target Version 0.11.0pre66 =>
2014-04-16 12:01 Christian Grothoff Relationship deleted child of 0003265
2014-05-11 14:05 Christian Grothoff Priority urgent => normal
2014-12-12 01:26 Christian Grothoff Note Added: 0008671
2014-12-12 01:26 Christian Grothoff Relationship added duplicate of 0003452
2014-12-12 01:26 Christian Grothoff Status assigned => resolved
2014-12-12 01:26 Christian Grothoff Fixed in Version => 0.11.0pre66
2014-12-12 01:26 Christian Grothoff Resolution open => fixed
2014-12-12 01:26 Christian Grothoff Assigned To Matthias Wachs => Christian Grothoff
2014-12-12 01:26 Christian Grothoff Target Version => 0.11.0pre66
2018-06-07 00:25 Christian Grothoff Status resolved => closed